Skip to main content

The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly


If you see this message in the Crawl log of a content source, make sure that the site(s) it is crawling are accessible from the index server. Often one of the following has happened:
  • The web.config file of the crawled web application contains an error. Especially if the crawl was working yesterday and suddenly it stopped, check the web.config file on the Index server by loggin on to the index server, browse the site and check for errors. Remember to edit the web.config to show detailed error messages (search for ‘stack’ and turn the stack trace to ‘on’, next search for ‘errors’ and turn to ‘off’. Browse again. Sometimes there are solutions which change the web.config through either: web.config.merge.xml file as part of the solution (you will find them in the CONFIG folder) or through the object model. Like adding your own custom navigation provider entry and so on. Duplicates in the web.config file (like duplicate trust level entries) etc are not allowed.
  • The target site collection contains a web part error for instance on the default.aspx. Although I did not encounter this myself I read a blog post that said the crawl error was solved by deleting the faulty web part from the site using SharePoint designer
  • Also check the solution are not deployed correctly.Central Administration -> Solution Management (Manage Farm Solutions)

Comments

Popular posts from this blog

SharePoint Game Webpart

http://spgameoflifewebpart.codeplex.com/ Goal: The Game of Life web part was created for a talk I presented at SharePoint Saturday New York in 2009. At the time, SharePoint 2010 was still in Beta and most people hadn't see the Enterprise Metadata Management (taxonomy) features. I used the Game of Life web part as an introduction to the new taxonomy API. I offered to provide the code, so here it is. Requirements ----------------------- - SharePoint Server 2010 with Enterprise Features - Visual Studio 2010 (inc. SharePoint tools) Setup ----------------------- 1. Add your account as a Term Store Administrator. This right is independent to Site Collection Administrator or Farm Administrator status. To open the Term Store Management Tool go to Site Actions > Site Settings > Site Administartion > Term Store Management. You can also  open the same interface from Central Administration > Manage Service Applications > Managed Metadata Service. 2. Run the sol...

CAML Query Helper Class

http://sharepointcamlhelper.codeplex.com/ https://camldotnet.svn.codeplex.com/svn/JohnHolliday.Caml.Net/CAML.cs CAMLManager mgr = new CAMLManager(); mgr.QueryGroups.Add(new QueryGroup("Title", Types.FieldTypes.Text, Types.QueryTypes.Eq, "A Title")); mgr.QueryGroups.Add(new QueryGroup(Types.JoinTypes.Or, "Title", Types.FieldTypes.Text, Types.QueryTypes.Eq, "Another Title")); mgr.QueryGroups.Add(new QueryGroup(Types.JoinTypes.And, QueryGroup.MergeTypes.Contain, "Total", Types.FieldTypes.Number, Types.QueryTypes.Geq, "2")); string caml = mgr.GetCAML(); Will provide the following: <Where>   <And>     <Or>       <Eq>         <FieldRef Name="Title" /><Value Type="Text">A Title</Value>       </Eq>       <Eq>         <FieldRef Name="Title" /><Value Type="Text">Another Title</Value>     ...